Categories
Broadband News Phones

Resolving a fault on a BT phone line and the BT brick wall

For the last few weeks, there has been intermittent noise on our BT phone line. At best, this makes telephone conversations difficult, but worse of all, it plays havoc with our ADSL router. For the last week the noise has been rather persistent, and our router is constantly dropping the connection, and reconnecting at much lower speeds due to the noise.

NB – updates are below this post.

As well as making it unpleasant to make calls, the speed of our broadband has gone from 11.65Mbs/1Mbs (down/up) to between 1.2Mbs/0.1Mbs and 4Mbs/0.3Mbs, if we’re lucky enough to get any connection at all. The router disconnects several times per hour and sometimes it’s hours before the noise has subsided and it can reconnect. Thank goodness that the 3G in Penzance is pretty reasonable.

Here is a recording that I made using my iPhone and a BT “quiet line test” (option 2 on 17070) to give you an example of what we’re dealing with.

I first reported the fault on 12 August, and a BT Openreach engineer (Openreach aren’t part of BT, but act as neutral maintainers of the old BT network) came round to have a look within a few days. I was quite impressed that they came round so quickly. Annoyingly, the crackling line wasn’t crackling when the engineer visited (you’ve got to love intermittent faults), and his test equipment didn’t show a fault with the line. But, erring on the side of caution, he stripped the wires of the incoming phone line and replaced the master socket. It was a few days before the crackling reappeared, so we initially thought that this had solved the problem.

Except that it hadn’t. It has come back and has become quite persistent.

To make sure that this wasn’t anything to do with our own equipment or wiring within the house, I changed every aspect of it, including the router (I have a spare) and microfilters. There are no hard-wired extensions in the house. The crackle was even there with a corded phone plugged into the master socket with nothing else involved. Same for a BT branded phone connected directly to an Openreach branded master socket.

On Sunday 19th August I called BT back on 151 and reopened the fault. An engineer visit was booked for today, from 1pm – 6pm, so I cleared my diary and made sure that I was home. I had made recordings of the noise and logged the erratic noise margins, line attenuation and output power on the line using the supplied BT Homehub 3 router to show the engineer in case the crackle went away again. I was well prepared, and looking forward to getting it fixed.

However, the time slot came and went, and no engineer turned up. At 6.25pm I dialled 151 and through the distortions and crackles successfully navigated through the complex menu options and spoke with an operator. However, they weren’t very helpful. The operator apologised and offered to make a new appointment for next Wednesday (6 days time). Clearly this was unacceptable, so I pressed to speak to someone higher up. A was promised a callback within 5 minutes to my mobile phone (the noise was unbearable and made communication hard on the landline). The callback hadn’t come 25 minutes afterwards, so I contacted BT via Twitter and sent in details of the case via their Twitter form. I was promised via Twitter that they would be in touch tomorrow.

At 8.30pm I was enjoying a walk after spending much of the day awaiting the BT Openreach engineer, when I received a call from the 151 operator’s supervisor. I was offered £10 compensation for the missed appointment and more apologies. I asked if it was too much for Openreach to let me know that they wouldn’t be able to make it, and I also asked what the reason was for them missing it. I was told that BT Openreach are so short of resources this happens to lots of people around the country. When BT request a reason why appointments are missed, Openreach rarely give a reason. If this is true, this is clearly an unacceptable situation, and if no clarity comes from my followups in the coming days, then Ofcom are the next step.

So where am I now? Well, the supervisor said that since my earlier conversation, where I was offered an appointment on Wednesday  – 6 days hence – there were no longer any slots on that day. The next available slot was on Thursday 30th between 8am and 1pm – a whole week away. It was claimed that there was absolutely no way for them to expedite my case and make it any sooner, and I would have to live with the fault until then.

I had hit the brick wall. I had no choice but to accept it. I was told that I would be called in a week’s time to follow up and check if the fault was fixed, and to discuss further compensation for lack of service.

I just want someone to check out my line, and perhaps have a look at the green box on the pavement to see what’s up. What I want rather than compensation is a working phone line as soon as possible, something I should have had today. Tehmina and I both work from home, so this is crucial to us.

That there is simply no way to get in touch with the local BT Openreach office to find out what has gone on, and how to put it right, seems quite ridiculous. At no point was I made to feel like a valued customer by BT, only half excuses were made, and stories told. However, with the way things are today, there is simply no alternative, so I must stare at the brick wall along with everybody else. I’m hoping for a better experience tomorrow if I get to talk to the @BTcare folk on Twitter, who helped me back in January, but I admit that I’m not confident anything will change.

Expect an update if anything changes.

(…And yes, my connection went down whilst writing this, and I had to post it using my phone which I’m not supposed to use for tethering! Still can’t connect after an hour.)

[Update – Friday 24 August] Today I spoke to a very apologetic member of BT’s social media team. He will try to find out from BT Openreach if there are any cancelled appointments in my area (Penzance, Cornwall) and will contact me on Monday if there are. If I don’t hear from him on Monday, I have to assume that the appointment will be next Thursday morning. He claimed that there is simply nothing that he can do to expedite my case. Right now, the noise is as loud as ever on the line and our router (BT Homehub 3) seems to have given up connecting and is occasionally showing a purple light on the broadband indicator, a colour I’ve never seen on it before, or no light at all. A reset allows it to connect briefly before randomly dropping out. I don’t think it’s happy having to connect and reconnect so often, poor thing…

[Update – 30 August 2012] The engineer visited today. He identified the fault, then called in a telescopic platform to be able to access the junction box outside the rear of our house where our neighbour’s line joins ours and goes on to the pole. They replaced the junction box “with a new type of join that’s more waterproof”, replaced the bracket, and re-routed the cable to another pole across the rear access lane. This new cable then looped diagonally back across the lane back to its original pole (2 sides of a triangle). The noise from our line has gone, and the quiet line test is quiet. Great. But. Our broadband speed, which used to connect (according to the router) at 13,500kbs (which according to speedtest.net gave us 11.75Mbs/0.96Mbs in real terms) now connects at 572kbs/440kbs. That’s very slow indeed. I’ve power cycled the router a few times, but it’s the same each time. So, unless it magically sorts itself out (a possibility), then it’s back to BT.

[Update 31 September 2012] I spoke with a member of BT’s social media team today, and they performed an SNR reset on my line. I was heading away for a long weekend, but by the time I left at the end of the day, my downstream had increased to 13,375Kbs down (much better!) and 442Kbs up (not really any different). I will wait until I return on Tuesday to see if the upstream returns to what it was. I am also to receive compensation for the missed engineer visit (£10 for an entire wasted afternoon, but better than nothing) and the days without service (or reduced service) on my phone line and internet accounts.  £23.20 in all.

[Update – 4 September 2012] Now that I’m back and the line has had a few days to stabilise, I decided to check the line speed again. 13,611Kbs down (great!), but still only 443Kbs up (not so great). I real terms on BT’s speedtester, it is 0.3Mbs, which used to give me a result of 0.98Mbs, so it’s about a third of what it used to be. A big deal if you upload lots (Dropbox, Flickr, YouTube etc) and rely on video calls (Skype). So this evening I replied to the email from BT sent after my conversation on Friday, and let them know the speeds I was getting. Within an hour (at 7.50pm) I had a call from a BT call centre, from someone who struggled to understand the problem I was having. I went though it all carefully, but they just didn’t get it. Fault on my line, Openreach fix it, broadband able to reconnect, slow speeds, SNR reset, fixes downstream, doesn’t fix slow upstream. I answered all questions, even reset my router to factory settings, and still I had to repeat the problem, repeating the ADSL line status information. When I was told to change the wireless channel to improve my upstream speed I had to insist that I be put through to someone who understands line attenuation and signal to noise ratios – he just didn’t get it. At 8.40pm I was transferred to a higher level tech support, who explained that the SNR reset performed on Friday will cause my line to go through a 10 day training period. So, roll on Sunday 9th September, and the return of our almost-1Mbs upload speed. Well, I can hope.

[Update – 16 December 2012] After months of patience and troubleshooting, I had to get back in touch with BT. I called their “expert helpline” and had a bad experience with the representative who was particularly surly with me. It caused me to complain via Twitter, and I was promptly contacted by very courteous and helpful person who listened patiently to my description of the problem. He was able to look at the settings and readings on my router and agreed that the upload speed was indeed much lower than I should be getting. He could see that there was a very high noise reading on the upstream, and arranged for another engineer visit. That was two weeks ago.

Yesterday, the engineer visited and was very thorough. He checked all of the wiring in the house, and fitted a new faceplate with a built-in ADSL filter, then checked our connection speeds with his own equipment and verified the upstream and downstream speeds, as well as checking the quality of the line. A simple request while he was here for an SNR reset resulted in the doubling of our upstream speed, also with an increase to our download speeds as well. We’re now at 888Kbs/14213Kbs up/down – a marked improvement on 443Kbs/13611Kbs we had before. The engineer explained that our profile had probably been based on the noisy level we had prior to September, and was set to a ‘safe and reliable’ level with the bias towards download (as most people are concerned with download rates).

So, I haven’t got my 1152Kbs upstream back, but I do have a big improvement to the slow upload speeds I had before. With luck, as there’s a 10 day training period, it may yet increase, but I’m happier to have an improved connection. It will do while I await BT Infinity, so, with luck, I can draw a line under this. Thanks to Jaimie at the BT Care team for helping out.

Categories
nokia e71 Phones Skype

Official Skype for Symbian S60 native client

At long last, Skype have released an official Skype for Symbian client.

I have it installed on my Nokia E71 and it works well. So far I have only two issues with it: when I lose 3G reception (which happens frequently where I live), despite having a preferred access point defined in the software, the client prompts you to choose an alternate AP. Now, if this happens while your phone is in your pocket, you aren’t going to see this message, and you aren’t going to be online. If you happen to go back into an area with reception, the client neither clears the access point prompt nor reconnects. This needs to be fixed.

The second is that the vibrating alert doesn’t seem to work. If my E71 is set to use the general profile, a normal Skype sound is played upon receiving an instant message or rings for an incoming call. Switch your phone to silent (where the vibrating alert kicks in for SMS and incoming calls) Skype doesn’t trigger a vibrating alert.

Now that I’ve got the negatives out the way (it’s been a long day) the client is excellent. File transfers, properly respected privacy settings (finally!) and  most of the other basic features (minus video calling) of a desktop client. It makes Skype a viable solution for me once more when I am out of the house (the one thing the 3Skypephone did very well was Skype presence and calling). I gave up with Fring and Nimbuzz as they interfered with my privacy settings, setting my desktop client back to calls and messages from contacts only, and it was annoying to remember to check them each time.

I have used the Symbian Skype client via both 3G and Wifi and placed test calls, both with adequate call quality. I have conducted a few text chats and this works well enough. In theory I could take a photo and send it to a chat recipient whilst out and about (something I liked about Fring), or have them send you a Word document etc. A minor quibble is that while text chatting you just start typing to bring up the text entry box. The trouble is, that first character simply invokes the box, and isn’t entered into it, meaning that you have to double-type the first letter of the first word of a new chat message. Not the end of the world, but it’d be nice to see that smoothed out, so you can just start typing a response naturally.

I’ll be using it extensively over the next few days and I’ll keep an eye on things like battery life to see how quickly it drains if Skype is run full-time. As I type, I have had the client running for 6 hours, and 2 bars have gone from the fully charged battery indicator. In theory, if I don’t use the phone much, I could get 18 hours out of it. We shall see.

To conclude, this is good news for the millions of Symbian S60 users out there, especially those of us with unlimited or generous 3G data packages or access to Wifi. No more having to use Skype credit at mobile rates to receive calls (a very welcome bonus). All is good. Let’s hope that the beta program gives Skype lots of feedback (do use their  Skype for Symbian forum to let them know of any problems) and hopefully we’ll all end up with a more robust Skype solution with better battery performance.

Fingers crossed.

Categories
Phones

The LG KC910 “Renoir”

Recently, my contract with 3 UK came up for renewal. Since I’m a frequent Skype user, I decided to stay with them and sign up for another 18 months. Despite loving my Nokia E71, a number of phones were offered to me free with my new contract. I plumped for the LG KC910 “Renoir” purely for its abilities as a camera – if I’m heading somewhere for the weekend, I can just take one device with me if I feel like it.

I’ve had it for a couple of weeks now, and, generally, I’m getting along with it.

The camera is just superb. The 8 megapixel camera is as good as any point and shoot, and the movie recording feature works wonderfully – my favourite setting being 640×384 widescreen – the video is crisp and colours well-defined. I’m very happy with the imaging functions, and that’s remarkable given how picky I am.

Conifer and Parasol

The video quality isn’t bad in low light either. Here’s a video taken at dusk, overlooking a river, with some bats playing over the surface of the water:

 

Bats on the River Avon from Tom Goskar on Vimeo.

The rest of the phone, well, after the E71, isn’t much to write home about. The interface is a bit clunky, the browser is passable, and the Java implementation is rubbish. But, it does the job – I can make and receive calls, and stab at the screen to send texts. I would *hate* to use it for Skype chat – the interface is just hideous – but making and receiving Skype calls works well.

I’m having trouble setting up my email too, which is annoying. It receives email fine, but sending an email with a photo attachment simply doesn’t work. This is doubly annoying, as it means that I can’t send photos to Posterous, Twitpic, Flickr, etc via email. I hope that I’ll work out how to fix it, or I’ll have to contact LG to see if they can help. 

Still, the camera came with an 8GB MicroSD card which is easily accessible via a flap on the side of the phone, so it’s easy to take it out, pop into an adaptor and transfer to my Mac. I managed to upload a photo to Flickr via the web browser, but it’s a fiddly process.

So what about build quality? It’s quite a chunky phone, made entirely from plastic, which is a stark contrast from the metal solidity of the E71. But it doesn’t creak or bend, and is nonetheless sturdy feeling for a plastic phone. The touchscreen is plastic, so prone to scratches, and is resistive rather than capacitive, so you need to press firmly (but not too hard) to register a ‘click’. You can of course see the touchscreen yield under your finger in the right light.

All round, it’s not bad. If I’m using my E71, I miss the KC910’s camera – but if I’m using the KC910, I miss the elegance of the E71, and it’s great physical keyboard. Any on-screen keyboard is a pile of rubbish compared to the iPhone’s implementation, in my humble opinion, this LG’s included.

Expect more opinions as I play more with the Renoir (especially if I fix the sending email attachments problem).